【题目描述】
试计算在区间1到n的所有整数中,数字x(0≤x≤9) 共出现了多少次?例如,在11到1111中,即在11,22,33,44,55,66,77,88,99,1010,1111中,数字11 出现了 44 次。
【输入】
22 个整数 n , x,之间用一个空格隔开。对于 100100% 的数据,1≤n≤1,000,000, 0≤x≤9。
【输出】
11个整数,表示 x 出现的次数。
【输入样例】
11 1
【输出样例】
4参考程序
- #include<bits/stdc++.h>
- using namespace std;
- int main()
- {
- int n,s=0;
- int x,y;
- cin>>n>>x;
- for(int i=1; i<=n; i++)
- {
- y=i;
- while (y!=0)
- {
- if(x==y%10)
- {
- s++;
- }
- y/=10;
- }
- }
- cout<<s;
- return 0;
- }